Jump to content
Sign in to follow this  
Patrick

Minimum Client Build

Recommended Posts

Hello,

Due to the recent news/discovery of the exploit detailed by TeamSpeak here, we will be setting a minimum build version of 3.0.18.1 once the latest update for iOS is available on the app store. This date has not been set in stone yet, but I expect it to be by the 25th of October at the latest. We will give you as much notice and remind you as much as we possibly can on a regular basis to prevent anyone from encountering issues.

Currently to protect our users from this exploit we have disabled the editing of channel descriptions in general across all channels including newly created ones. If you really wish to change this immediately, you can contact a member of staff and they can seek approval of the channel description from either myself or a higher member of staff for it to be set. Alternatively, you can contact me directly on TeamSpeak and I will look into your request if I am not too busy. Please note I may not reply immediately but I will get back to you ASAP.

What does this mean for anyone running a version under 3.0.18.1?

In simple terms, you wont be able to join our server unless you update to a recent patch. We're not willing to compromise the security integrity of anyone's computer to allow the few people who may be unable to update to 3.0.18.1, for any reason. My main priority right now is protecting you from being hit by this exploit. On attempted connect, it will prompt you that to connect you will be required to update and it will offer you the option to check for an update.

I'm aware that some people do run TeamSpeak due to having older CPU's due to the recently changed system requirements of TeamSpeak in one of the more recent builds. This reason is a pressing one to myself, but it will have to be overlooked due to the severity of this exploit and we will be setting the minimum client version to 3.0.18.1 without any hesitation.

If you have any questions, please reply below and I will answer them ASAP.

Edit/Update:

I have decided to force minimum client build early due to the low amount of iOS users, as of now you need to be running 3.0.18.1 to connect to our TeamSpeak server.

Regards,

Patrick

Share this post


Link to post
Share on other sites

Hey Patrick, when I go Help > Check for updates it displays "You are already running the latest version"

I presume this means I am running a stable version of teamspeak and my computer is not at risk of this exploit?

Regards

Mike/Towey

Share this post


Link to post
Share on other sites
Hey Patrick, when I go Help > Check for updates it displays "You are already running the latest version"

I presume this means I am running a stable version of teamspeak and my computer is not at risk of this exploit?

Regards

Mike/Towey

Hi Mike,

I've just checked and you're running 3.0.18.1 which means you are safe from this exploit :)

Regards,

Patrick

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...